Preparing Objects for Bryce using MeshLab

Bryce can import many different object formats directly. But not all and
some are just too detailed and have a file size Bryce cannot handle
anymore. Such objects have to be reduced in resolution.

Preamble

There are a couple of beautiful mesh objects from real models that were scanned three-dimen-
sional by the Stanford Computer Graphics Laboratory and are freely available for download
from the Stanford 3D Scanning Repository:

http://graphics. stanford. edu/ dat a/ 3Dscanr ep/ .

If you download and use these models, please read carefully at least the paragraphs Please
acknowledge... and Inappropriate uses of these models. The models are available in the PLY file
format which Bryce cannot read.

This small tutorial uses MeshLab to do the file format conversion and the mesh reduction. The
program is free and can be downloaded from ht t p: / / neshl ab. sour cef or ge. net/ for the PC.

The tutorial is based on information generously given by LordHardDriven in the DAZ 3D
Bryce Forums and my own endeavours. Thank you Mark!

MeshLab

It is assumed that MeshlLab is installed and PLY files from the Stanford 3D Scanning Repository
are used, though MeshlLab can handle a lot of different file formats. The best “bet” for Bryce is
using the Wavefront OBJ format.

PLY and OB]J File Formats

The Stanford Polygon File Format PLY files are ascii files and their file size is about half of a
Wavefront Object OB]J file, which is also an ascii file.

bun_zipper01.ply bun_zipper01.obj

ply it

format ascii 1.0 #

conment zi pper out put # OBJ File Generated by Meshl ab

el ement vertex 35947 #

property float x #it##

property float y # Obj ect bun_zi pper. obj

property float z #

property float confidence # Vertices: 35947

property float intensity # Faces: 69451

el enent face 69451 #

property list uchar int vertex_indices #it##

end_header vn 1.223420 6.106969 -0.789864

-0.0378297 0.12794 0.00447467 0.850855 0.5 v -0.037830 0.127940 0.004475 0.498039 0.498039 0.498039
-0.0447794 0.128887 0.00190497 0.900159 0.5 vn 1.351736 5.963559 -1.435807

-0.0680095 0.151244 0.0371953 0.398443 0.5 v -0.044779 0.128887 0.001905 0.498039 0.498039 0.498039
-0.00228741 0.13015 0.0232201 0.85268 0.5 vn 0.367206 5.014973 3. 728925

-0. 0226054 0.126675 0.00715587 0.675938 0.5 v -0.068010 0.151244 0.037195 0.498039 0.498039 0.498039
-0. 0251078 0.125921 0.00624226 0.711533 0.5 vn -0.385074 6.089025 1.435442

-0. 0371209 0.127449 0.0017956 0.888639 0.5 v -0.002287 0.130150 0.023220 0.498039 0.498039 0.498039
0. 033213 0. 112692 0.0276861 0.652757 0.5 vn -1.639362 6.038991 -0.564704

0. 0380425 0.109755 0.0161689 0.708171 0.5 v -0.022605 0.126675 0.007156 0.498039 0.498039 0.498039
-0. 0255083 0.112568 0.0366767 0.454541 0.437538 vn -1.262990 6.122241 -0.580414

-0.0245306 0.112636 0.0373469 0.448754 0.455187 v -0.025108 0.125921 0.006242 0.498039 0.498039 0.498039
0.0274031 0.12156 0.0212208 0.533079 0.5 vn 1.709938 5.964254 -0.979467

-0.0628961 0.158419 -0.0175871 0.404517 0.5 v -0.037121 0.127449 0.001796 0.498039 0.498039 0.498039
0. 0400813 0.104202 0.0221684 0.535542 0.5 vn 4.557332 3.207902 2.899741

0. 0451532 0. 0931968 0.0111604 0.579563 0.425995 v 0.033213 0.112692 0.027686 0.498039 0.498039 0.498039
-0. 0324965 0.174231 -0.00238999 0.365607 0.5 vn 0.000000 0.000000 0.000000

-0. 0804587 0.135827 0.0500319 0.499575 0.5 v 0.038043 0.109755 0.016169 0.498039 0.498039 0. 498039
-0.0724944 0.126022 0.052902 0.564827 0.5 vn -2.456123 4.031157 4.120945
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http://graphics.stanford.edu/data/3Dscanrep/
http://meshlab.sourceforge.net/

Importing, Remeshing and Exporting an Object
If there is already a project open, click on File > New Empty

ﬂlee Edit Filters Render View Windows Toals

Project or hit Ctrl+N. Always start with an empty project. “— ~ NewbhplyPiopct.. GO
To import a mesh in any format supported by MeshLab, like g o= €
PLY, click on File > Import Object or hit Ctrl+l as shown at & save Project Chi4s
”ght Close Project

The file open dialog appears and you can select the file you @ E Chi
want to convert. Depending on its size, this will be swift or :

take a few seconds. At the bottom of the MeshLab window, a i S
bar shows the progress. E——

Once the file is loaded, the object can be rotated and tilted ' Save snapshot

and be viewed in 3D. There are many view options of which Recent Projects
we investigate none. | do not know MeshLab intimately and Recent Fes
out goal here is to reduce resolution and export as OBJ.

Exit

Once the object is loaded, here the bunny, we have to select everything that makes up this
object. Click on Filters > Selection > Select All. It may take a moment until the second drop
down appears. See picture below.

€ MeshLab v1.3.2_64bit - [Project_1]

® File Edit | Filters Render View Windows Tools Help

.'_‘]}g f Apply filter
| L Show current filter script

Selection Conditional Face Selection
Cleaning and Repairing Conditional Yertex Selection
Create New Mesh Layer % Delete Selected Faces
Remeshing, Simplification and Reconstruction % Delete Selected Faces and Vertices
Foiyganal and Quad Mesly ¢ Delete Selected Vertices
Color Creation and Processing Dilate Selecti
a on
Smoothing, Fairing and Deformation L
Quality Measure and Computations e
lection
Mormals, Curvatures and Crientation e ey
wve Zero Area Faces

i

:sn:ef ;Z:;a Select Bof Select all the faces of the current mesh
§ Select Faces by Color

Paoint Set Select Faces by Face Quality

Sampling Select Faces by Vertex Quality

Texture Select Faces by view angle

Camera Select Faces from Vertices

Select Faces with edges longer than. ..

Select None

Select Redundant Faces

Select Self Intersecting Faces

Select Vertex Texture Seams

Select Vertices from Faces

Select Visible Paints

Select non Manifold Edges

Select non Manifold Vertices

Small compaonent selection

When done, the small dialog Select All appears (shown above at lower left). Just click on
Apply and after a moment, the object gets almost fully red because there are so many faces
and vertices.



The status line shows that the mesh bun_zipperO1.ply is loaded, that it has 35,947 vertices and
69,451 faces.

Now to reduce these faces to half that amount, click on File > Filters > Remeshing,
Simplification and Reconstruction > Quadratic Edge Collapse Decimation. It may take a short
moment until the second drop down appears.

G’ Meshlab v1.3.2_64bit - [Project_1]
& File Edit | Filters Render View Windows Tools Help

= Apply filter Select All Cirll  fecs e ’* 3 ’?\I ’* g e [
H - E Show current filter script ate @ @ i =1 ?‘i 1 17 @ - @ 'J_ (f 14 .
Selection
e
Create Mew Mesh Layer Simpiity 8 mesh using 3 Quadiic based Edge Colaose
|--__-_. T 7 T . Strateqy, betfer than dustening but slower
ification and Reconstruction Alpha Complex/Shape

Polygonal and Quad Mesh CSG Operation Target number of faces | 34725
Color Creation and Processing Close Holes

) . y Percentage reduction (0., 1) |0

Smoothing, Fairing and Deformation Clustering decimation

Quality Measure and Computations Erwiaesr Hl Quality threshold |0.3

Mormals, Curvatures and Orientation Crease Marking with NonFaux Edges [~ Preserve Boundary of the mesh

Mesh Layer Curvature flipping optimization Boundary Preserving Weight |1—

Raster Layer Cut mesh along crease edges

Range Map Delaunay Triangulation I [Preserve Narmal

Point Set Iso Parametrization I~ Preserve Topology

Sampling Iso Parametrization Buid Atlased Mesh I Gt postion of simplified vertices

Texture Iso Parametrization Load Abstract Domain

Camera Iso Parametrization Remeshing | e
150 Parametrization Save Abstract Domain I™ Weighted Simplification
Iso Parametrization transfer between meshes v Post-simplification deaning
Marching Cubes (APSS)
Marching Cubes (RIMLS)
Mesh aging and chipping simulation Default |
Planar flipping optimization
Points Cloud Movement Close |

W simplify only selected faces

ation {with texture)
Refine User-Dl Simplify a mesh using a Quadric based Edge Collapse Strategy, better than dustering but slower
Simplfication: MC Edge Collapse
Subdivision Surfaces: Butterfly Subdivision
Subdivision Surfaces: Catmull-Clark
Subdivision Surfaces: LS3 Loop
Subdivision Surfaces: Loop
Subdivision Surfaces: Midpoint
Surface Reconstruction; Ball Pivoting
Surface Reconstruction: Poisson
surface Reconstruction: VCG
Tri to Quad by 4-8 Subdivision
Tri to Quad by smart triangle pairing "

Then, the dialogue Quadratic Edge Collapse Decimation pops up. The field labelled Target
number of faces shows half the number of faces indicated on the status field at the bottom. |
really do not completely understand how the other parameters in the dialogue ought to be
set, keeping them at the default proved to be a valid setting.

Depending on the complexity of the mesh object, the quadratic edge collapse decimation
may finished in a second or two, like for the bunny, or may take several minutes. The picture
above shows on the lower edge at right where the bar will appear that shows the progress of
the operation.

Once the operation is concluded, you have a mesh that is only half the resolution of the
original one. It is time to save it - or rather - export it. It can be exported to the target file
format, OBJ in the case of Bryce, or again as PLY. If you intend to half the resolution once
more, it does not matter whether you import the exported PLY or OBJ. However, it is
important that you give the exported file a name that helps you to identify how much the
resolution was reduced and be careful not to overwrite the original.

To export, click on File > Export Mesh As... The Save As dialog appears.
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G’ MeshlLab v1.3.2_64bit - [Project_1]
ﬂﬁle Edit Filters Render View Windows Tools Help

" New Empty Project. . cirl+n = T R e v ||| I
J‘_ﬁ;‘ Open project... crl+0 =z ‘“Eﬂ "’TEE @ @ i : “ ! ‘@. & @y A‘

Append project to current. ..

% SaveProject cri+s
Close Project

i Import Mesh, ., Ciri41

& ExportMesh... Cirl+E

4 Export Mesh As...

" Reload Ctrl+R
Reload Al Cirl+Shift+R

&/ Import Raster.,

& Save snapshot

Recent Projects LS
Recent Files G Choose Saving Options for: "bun_zipper01.ply’ e |

Exit —vert —Face —Wedge —Texture Mame
I Flags ™ Flags ™ calar
v Color I= ‘Colar ™ niormal
!_7 Quality = ‘Duality [~ Textonrd
™ Mormal I Mormal
I= TexCoord
I” nadius Rename Texture I

—Additional Parameters

¥ Binary encoding

= Al I™ Camera

[~ Help oK Cancel

¢ Mone ™' Falvgonal

After the file has been given a name, the dialogue Choose Saving Options for “filename.typ”
(here bun_zipper01.ply) pops up. The model has no texture applied and hence the default
settings can be acknowledged by clicking on OK.

If you wish to further reduce the resolution, start again by opening a New Empty Project and
import the exported model. Then select all and do the Quadratic Edge Collapse Decimation
again, export, and so on.

Please be aware that those meshes can be quite large. | could import a mesh of 615 MB as
OBJ into Bryce (xyzrgb_dragon) but could not save the Bryce file, nor could | save the object
to the library. All | could do was export it as 3DS from Bryce, but that did not help matters.
The 864 MB file (xyzrgb_statuette) prompted an Out of Memory error in Bryce, even though |
have Bryce Large Address Aware.

This means that you may have to reduce the mesh resolution several times. In fact, | went as
far as to 1/64 of the original resolution - though in steps. It depends how large the object will
be rendered in Bryce and how far away it is from the camera. A low resolution model may be
sufficient in one case and a high resolution one mandatory in another.



Bryce

Once you have the object(s) in one or several resolution(s) in
the Wavefront OBJ file format, you can use them in Bryce by
importing.

Click on File > Import Object and the Open dialogue pops up.

Select the mesh. The OBJ Import dialog opens. Though it comes

W without any material, the option Obj
group material is fine.

U3 S proT s

Grouping mede
s Matcrial Depending on the size, it will be loaded
in a second or two, or in half an hour or

even longer.

+ Objgroup
¥ Objgroup material

o The xyzrgb_dragon took 39 minutes to
load in the full resolution; the xyzrgb_ statuette generated the
Out of Memory error after 1 hour 10 minutes. The bunny took
5 seconds at most in the full resolution.

The size in which the i) Bryce 7.1 Pro
File Edit Objects Links Help

objects appear varies. -
The bunny is tiny and
will have to be enlarged. 3
Other meshes are very

large and have to be % Tl e
reduced in size. This is K‘)

best done with the Trans- v - Hnscaie
for‘mation tool in Bryce. q'“‘_?ﬁe‘h Fip X
Edit > 3D Transforma- 4 e E:;
tions opens the respect- e

tive dialogue. -

jat. Bryce 7.1 Pro
File Edit Objects Links Help

Mew Document... Ctrl+
Document Setup... Ctrl+Alt+
Animation Setup... Ctrl-+5hift-+Hd
Open... Ctrl+0
Merge...
SaEVE Chrl+-5
Save As... Ctrl+5hift+5
Rewvert bo Saved Chrl+-AlE+5
Open Image...
Save Image As...
Export Image...

Import Object...

Export Object.,

Send to DAZ Studio...

Render Cirl+R

Clear and Render Ctrl+Alt+R
Render to Disk...
Render Animation... Alt+Shift-+R

Metwork Render Manager...

3D Transformations

omeet| 0 J[ 0 ]D |

Remte | 0 J[ o J[ 0 }°

sire | 2500 | [ 2500 2500 |%
X Y Z

The example above shows a size for X, Y and Z of 2,500%. This makes the bunny 25 times

larger. The Armadillo had to be reduced to a fifth, i.e. to 20%.

Each model you import can be saved to the Objects Library for later use. To save the model to
the Objects Library, select the object and click on the arrow right of Create. This opens the

library. Navigate to sub-library and click on Add.

Objects

Bryce converts the import
file format to an internal
one. The object is loaded
from the Objects Library
faster and if a material was
applied to it, the material
is saved along with the
object in the library.

bun_zipper01

hitpzifgraphics.stanford.ed
rizduction with MeshLab. {Homo}

You can add a sub-library,
give the object a title and
add a description.

A library must never reach
2 GB, all is lost if it does.

Horo -

Resalution 1:1; size: x 25; 6.0 MB; Bunny. From the Stantord 30 Scanning Repository:
atalGhscanrepd. PLY files converted to obj and resolution
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